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Template error

Symptoms

An issue does not get synchronized and appears in the troubleshooting section with the category 'Template error'  and a message such as

Unable to apply the custom template (${version.name} (${version.description) for the field (free text field) and field Id (customfield_10600)

or

Unable to apply the custom template (${user.displayName} (${user.emailAddress) for the field (single line text) and field Id (customfield_11200)

Cause

The template used probably has a syntax error.

You need to correct the syntax, edit the configuration, and that will fix the field mapping with the wrong template.

Once you've done, navigate to the troubleshooting tab, and retry the synchronization.

Resolution

User

In the field mapping configuration, you can enter the text string in the Custom User Format text box:

You can use the following placeholders in the text string:

PlaceholderDescription
${user.displayName}
the user's JIRA display name
${user.name}
the user's JIRA log-in name
${user.emailAddress}
the email address associated with the user's JIRA account

Version

In the field mapping configuration, you can enter the text string in the Custom Version Template text box:

You can use the following placeholders in the text string, (the version's values displayed depends on how you configured these values in the project settings page):

PlaceholderDescription
${version.id}the version's JIRA id
${version.self}the version's JIRA self URL
${version.name}
the version's JIRA display name
${version.description}
the version's JIRA description
${version.releaseDate}
the release date defined for this version
${version.released}
true if released, false otherwise
${version.archived}
true if archived, false otherwise

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