Skip to main content
Skip table of contents

Server is not reachable - how to fix it

Symptoms

When creating a new synchronization there is a validation error for the Base URL field: "The server '%baseUrl%' is not reachable"

Cause

This happens (typically on Unix servers) when the networking is setup in a certain way that Java cannot handle it correctly.

As Backbone uses the HTTP(s) protocol to talk to itself and depending on your set up also to the other instance, the server must be able to resolve the Base Urls, but it can't.

Resolution

The following steps should be done in order to resolve this problem. Let's assume your server's IP address is 1.2.3.4, the JIRA server's hostname is jiraserver and the domain of the server is jira.example.com . Please replace those assumptions with your values.

  1. Open the file on /etc/hosts (on Lunix) or \WINDOWS\system32\drivers\etc\hosts (on Windows) and check if there is a line for your IP address containing the hostname (short version and fully qualified). The line should look like

    CODE
    1.2.3.4 jiraserver jira.example.com
  2. If there is a line like

    CODE
    127.0.0.1 localhost localhost.localdomain jiraserver jiraserver.local jira.example.com

    please split it into two separate lines and replace the loopback IP (127.0.0.1, ::1) with the actual IP of your server. The result should look like this:

    CODE
    127.0.0.1 localhost localhost.localdomain
    1.2.3.4   jiraserver jiraserver.local jira.example.com

 

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.