Invalid license
Symptoms
An error happened while Backbone tried to synchronize changes to this issue. The issue appears on the troubleshooting screen with the category 'Invalid license', even though the license is definitely valid.
Cause
This error can have multiple causes, all related to the Jira systems not being able to communicate with one another for some reason.
Resolution
- Make sure that both instances can reach each other in a server-server scenario. You can test that by executing the following command on your server (where Backbone is installed) in your terminal/command line:
curl -u sync_user_name:sync_user_password JIRA_BASE_URL/plugins/servlet/backbone-issue-sync/api/1/licensing/license
This call should return a small JSON response and include some text like "valid: true" => if no JSON is returned (e.g. an HTML is generated), it means something is wrong
- If you use a 2-factor-authentication add-on for your Jira system, please make sure that the path /plugins/servlet/backbone-issue-sync/* does not require 2 factor authentication. Instead, basic authentication must be usable for the Backbone synchronization user
- If you're using a proxy, make sure that your proxy can reach the Jira system(s) (please bear in mind that because of BAC-1045 you may have problems when using https proxies)