Missing issue type mapping
Symptoms
An issue does not get synchronized and appears in the troubleshooting section with the category Missing issue type mapping and a message such as Message (id=PRJ-HOSTNAME-58147-1500284440295-1-8531) does not have a corresponding issue type mapping.
Cause
Cause 1
A possible cause for this problem is that the configuration was changed after the issue was created – for example, if an issue type mapping was removed or the mapping direction was changed.
Cause 2
An issue A-1 has been synchronized and resulted in some error in the troubleshooting. Then you've changed the issue type of A-1 to an issue type which is not defined in the Backbone configuration. You triggered a resync which tried to synchronize A-1 since Backbone already knows it.
Resolution
Cause 1
You can try to fix the problem by doing one of the following:
- perform a resync for the specific issue by applying a filter like
issueKey=PRJ-7
in the JQL resync section - manually delete the corresponding message file PRJ-HOSTNAME-58147-1500284440295-1-8531.bac in the Backbone folder. The file can be found under your JIRA_HOME directory in a subfolder like data/backbone-issue-sync/default/INT-X/PRJ-Y/RECEIVE/error, where this substring INT-X/PRJ-Y and the actual location of the message file depend on your specific configuration
Cause 2
You can try to fix the problem by doing one of the following:
- Change the issue type for this issue to one who is configured inside Backbone and perform a resync for this issue.
- Change the Backbone configuration in order to include this issue type and perform a resync for this issue.