Symptoms

An issue does not get synchronized and appears in the troubleshooting section with the category Cannot create new issue and a message such as Cannot create new issue without mapped issue type for received issue PA-123.

Cause

The most common reason for this error is that there is a field that is appearing on a screen more than once. CreateIssueMeta returns Duplicate Key error

Resolution

  1. Run the following SQL query towards the database to see if there is a duplicate field in a screen:

    select f.name, i.fieldidentifier, count(*)
    from fieldscreen f, fieldscreenlayoutitem i, fieldscreentab t
    where f.id = t.fieldscreen
    and i.fieldscreentab = t.id
    group by f.name, i.fieldidentifier having count(*) > 1;
    CODE
  2. Does running the query return a result? If there is no result, please open a support ticket at support@k15t.com. If there is a result shown by running the query above, it means that there is a duplicate in a screen. To remove it, follow the steps below:
    1. Navigate to JIRA Administration > Issues > Screens
    2. Look for the Screen mentioned in the SQL query result
    3. Click Configure and look for the mentioned field
    4. Remove one of the fields from the screen