Manual
-
Basics
-
Runtime
-
Example Use Cases
- Bidirectional synchronization
- Unidirectional synchronization
- Synchronize Jira Server with Jira Cloud
- Synchronize one project with multiple others
- Synchronize a private with a public project
- Synchronize projects behind firewalls
- Synchronize without installing
- Synchronize with changing partners
- Migrate Jira projects
-
Centralized configuration
-
Distributed configuration
-
Troubleshooting
- Analyze and fix errors
-
Error message reference
- Admin or project admin permissions are required
- 411 - Length required
- Bad gateway
- Cannot create new issue without mapped issue type
- Cannot find transition
- Cannot find transition id
- Component(s) not valid
- Field not on the Screen
- Incoming Issue Error
- Incompatible message format
- Invalid license
- Invalid regex syntax
- Issue does not exist
- Issues must be assigned
- JIRA is offline
- Missing attachment permissions
- Missing Issue
- Missing issue type mapping
- Missing message
- Missing required fields
- No create version permissions
- No permissions to view this request for JIRA Service Desk
- No project administration permissions
- Option not valid
- Outgoing Issue error
- Outgoing Send Error
- Priority not valid
- Resolution cannot be chosen
- Server is not reachable - how to fix it
- Sprint does not exist
- Template error
- The requested board cannot be viewed
- User does not exist
- User not assignable
- Version(s) not valid
- Workflow operation not valid
-
Fix common problems
- Changes are not being synchronized
- Sync info panel displays wrong synchronization name, and no link to partner project
- Can't change the synchronization user
- All fields have English names although Jira is in a different language
- Recently created issue types, fields, etc. are not available when editing configuration
- Authentication with an external Jira fails
- Exception: ServiceLocatorImpl has been shut down
- Configure email error notifications
- Increase the JIRA logging level
-
JIRA Service Desk
-
Reference
-
Administration
Missing required fields

Roman Serazhiev Last update: Sep 1, 2017
Symptoms
An issue does not get synchronized and appears in the troubleshooting section with the category 'Missing required fields' and the message, e.g. "customfield_10200":"Text field is required." or "description":"Description is required.".
The 'customfield_10200' part identifies the internal id of the field which is affected.
Cause
The issue sent from the other side does not contain a value for the required field. This might be due to the following reasons:
- The corresponding field is not mapped via Backbone and therefore no value is set by Backbone.
- The corresponding field is mapped via Backbone, but the issue on the sender side does not have a value.
Resolution
There are different approaches how to resolve this situation:
- Make the corresponding field optional, see the JIRA documentation for detailed steps. Please perform a retry afterwards.
- Make sure that you've mapped the field with Backbone and provided a value in the issue on the senders side. Please perform a resync for this issue afterwards.
2xlatest