Resolve "Broken Document Link
This troubleshooting article provides step-by-step guidance for how to resolve the error message "Broken document link".
Symptoms
When attempting to manage your document page trees, you encounter the following error message in the document toolbox:
"Broken document link"
Possible Causes
The document version associated with the page tree may have been deleted by a user who had access to the document, but not to this particular page tree.
Thus, the document’s reference to this page tree was deleted, but the page tree metadata still says it’s part of that document.
Troubleshooting
To start troubleshooting, follow the steps below:
Navigate to one of the pages in your page tree.
Click Document toolbox, and if you see the error message "Broken document link", proceed to the next step.
Click Manage to open a new dialog providing more information about the issue.
Click Remove link to disconnect the page tree from the document.
If the page tree needs to be re-added to the document
If the page tree was deleted from the document by mistake and needs to be re-added, follow these steps to define the page tree as a version:
Navigate to the document manager
Select ••• > Advanced options > Add existing page tree
In the dialog, select the root page of the page tree you would like to add to the document and select Next.
Re-add the version name and description and select Save.
The page tree is now a proper document version! 🎉
Alternative Solutions
If the issue persists after following the steps above, don’t hesitate to reach out to our support team for further assistance: help@k15t.com. When reaching out to us, don’t forget to provide detailed information about the problem, including the steps you have taken to reproduce, and an error json containing the error.