×

You're using an outdated browser

For a better experience, keep your browser up to date. Check here for the latest version.

Manual

Scroll PDF Exporter 4.0 Upgrade Notes

Thomas Walker

Thomas Walker Last update: May 30, 2017

Below are some important notes on upgrading to Scroll PDF Exporter 4.0. For details of the new features and improvements in this release, please read the Scroll PDF Exporter 4.0 release notes.

Confluence versions 5.9.0-5.9.3 are not supported

Scroll PDF Exporter 4.0 does not support Confluence versions 5.9.0-5.9.3.

Your old templates from PDF Exporter 3.x are still supported – but not for ever

Scroll PDF Exporter 4.0 introduced a new way of designing templates with the visual WYSIWYG editor.

You can still edit and export with your existing templates and export schemes in the current version – but support will be removed in a future version.

We recommend re-creating your old templates in the new template editor as soon as possible. If there are any features missing from Scroll PDF Exporter 4.0 that are blocking you from re-creating your old template, please reach out to us at support@k15t.com.

It is possible to roll back Scroll PDF Exporter 4.0 to an earlier version

If you are using Scroll PDF Exporter 4.0, you can roll back to earlier versions of the add-on.

Support for Comala Workflows is not yet included (but we're working on it)

Scroll PDF Exporter 3.5 featured Comala Workflow integration – this has been removed for new templates created in version 4.0 (but still works for your old templates created in Scroll PDF Exporter 3.x and earlier, though).

But it's not gone forever – we're working on building an improved, more stable integration in a future version.

After installing Scroll PDF Exporter 4.0, you need to upgrade most of your other Scroll Add-ons

When you upgrade to Scroll PDF Exporter 4.0, you need to update most of your other Scroll Add-ons

Scroll PDF Exporter 4.0 runs on the new Scroll Runtime 2.0 platform – when you upgrade to Scroll PDF Exporter 4.0, Scroll Runtime 2.0 is automatically installed.

The following Scroll Add-ons are incompatible with Scroll Runtime 2.0, and need to be updated after installing Scroll PDF Exporter 4.0:

  • Scroll Versions/Scroll Translations/Remote Publishing Endpoint/Comala Workflows for Scroll Versions must be upgraded to version 3.6 or later
  • Scroll Acrolinx Connector must be upgraded to version 3.1 or later
  • Scroll Viewport must be upgraded to version 2.7 or later

End of life policy

With this release, we are also introducing our new end of life policy.

We're following the same end of life policy as Atlassian. Our add-ons will support all versions of Confluence that have been released within the last two years of the release of a new add-on version.

You can find further details until when specific versions are supported in the Atlassian End of Life policy.

2x4.2
We use cookies to create a secure and effective browsing experience for our website visitors and to understand how you use our site (i.e. Google Analytics). For more information: click here.
Ok