Skip to main content
Skip table of contents

Resolve "Failed to acquire lock for" Error

Problem

The space is locked and the error message "Failed to acquire lock for..." is thrown

Prerequisites

To unlock a space the support resource must be enabled. To enable the support resource follow these steps:

  1. Navigate to Space tools > Scroll Add-ons

  2.  Press the ALT/Option key on your keyboard to make a menu entry for Advanced Plugin Settings appear.

  3. Click on Advanced Plugin Settings

  4. Change the dropdown to Scroll Platform.

  5. Look for "enable.support.resource" in the list of Keys.

  6. Click Edit and set the value as "true."

Resolution

Copy the following command to the browser URL field, replace the values in "< >" and hit Enter: http://<host>:<port>/<contextpath>/rest/scroll-versions/1.0/support/release-publishing-lock/<space_key>

For example: http://localhost:1990/confluence/rest/scroll-versions/1.0/support/release-publishing-lock/PLOCK

To unlock all spaces use this URL instead: http://<host>:<port>/<contextpath>/rest/scroll-versions/latest/support/locks/locked/unlock

If you are publishing to a remote Confluence system and your target space is locked, navigate to the remote Confluence system and send a DELETE request using the following URL: 

<confluence-url>/rest/scroll-remote-publishing-endpoint/1.0/space/<spaceKey>/publishing-lock

Cause

We lock a space when there is an action from the app that is still in progress, for example publishing a version, deleting versions or when the app upgrades. When any of such actions are interrupted by Confluence shutdown or crash, the lock has to be removed manually.


JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.