In Confluence 5.8 and 5.9 pages that were migrated from an earlier version of Confluence and contained a Content by Label macro could show a "Macro Rendering Error". This is caused by a broken macro migration in Confluence that only appears under certain conditions (see: CONF-39582).

To repair pages with this issue, make sure Scroll Versions is updated to 2.8.10 or higher. You can perform the repair across your entire system, or in a specific space.

  • To repair the issue across the whole system, access /spaces/com.k15t.scroll.platform/scroll-confluence58-repair-content-by-label.action
  • To repair the issue in a specific space, access /spaces/com.k15t.scroll.platform/scroll-confluence58-repair-content-by-label.action?key=spaceKey