December 2022

Scroll Versions 4.4.0 is a compatibility release that introduces support for Confluence 8. In order to ensure compatibility with Confluence 8, we've made changes to how Scroll Roles interact with the Scroll Viewport search. 

The changes have impact only for users who have enabled Scroll Viewport in their Versions or Scroll Translations-managed space. For search to work, we recommend:

This release also fixes a bug related to specific page restrictions preventing pages from being migrated during a migration to Scroll Documents.

Important Update Information for Scroll Apps

Due to the required compatibility changes for supporting Confluence 8, the following Scroll Apps should be updated to the latest compatible version at the same time. This is required so that the shared elements, that all these Scroll Apps use, are running the same latest supported version.

Confluence 8 compatible versions:

  • Scroll Viewport v2.21.0
  • Scroll Versions v4.4.0
  • Scroll Translations v4.4.0
  • Scroll PDF Exporter v5.9.0
  • Scroll Word Exporter v5.9.0
  • Scroll CHM Exporter v3.10.0
  • Scroll DocBook Exporter v3.10.0
  • Scroll EclipseHelp Exporter v3.10.0
  • Scroll EPUB Exporter v3.10.0
  • Scroll HTML Exporter v3.10.0


Important Note for Comala Document Management for Scroll Versions/Exporters

Currently, we do not yet have compatible versions of our Comala Document Management integrations apps with Confluence 8. This relates to:

This means if you use either of the following apps we recommend to not yet update to the relevant Confluence 8 compatible versions of the Scroll Apps mentioned above. We would only recommend updating once Comala Document Management is marked compatible with Confluence 8 and once we have released compatible versions for the integrations apps.