December 2022

We're pleased to announce the release of Scroll Viewport 2.21.0, which is a compatibility release. It introduces app compatibility with Confluence 8. This release contains changes to search that ensure compatibility with Confluence 8 and modify the integration between Scroll Viewport and Scroll Versions and Translations.

The changes have impact only for users who have enabled Scroll Versions or Scroll Translations in their (Viewport enabled) space. For search to work, we recommend:

  • You should not use Scroll Roles. If Scroll Roles are defined, then versioned pages won’t be returned by the search (in Confluence or Viewport) for users that are not members of the defined Scroll Roles.

  • You should use Scroll Search.

The changes apply if you use any Viewport version from 2.21 on, even if you are not running on Confluence 8. If you were using Scroll Search before, nothing will change for you.

Important Update Information for Scroll Apps

Due to the required compatibility changes for supporting Confluence 8, the following Scroll Apps should be updated to the latest compatible version at the same time. This is required so that the shared elements, that all these Scroll Apps use, are running the same latest supported version.

Confluence 8 compatible versions:

  • Scroll Viewport v2.21.0
  • Scroll Versions v4.4.0
  • Scroll Translations v4.4.0
  • Scroll PDF Exporter v5.9.0
  • Scroll Word Exporter v5.9.0
  • Scroll CHM Exporter v3.10.0
  • Scroll DocBook Exporter v3.10.0
  • Scroll EclipseHelp Exporter v3.10.0
  • Scroll EPUB Exporter v3.10.0
  • Scroll HTML Exporter v3.10.0

Important Note for Comala Document Management for Scroll Versions/Exporters

Currently, we do not yet have compatible versions of our Comala Document Management integrations apps with Confluence 8. This relates to:

This means if you use either of the following apps we recommend to not yet update to the relevant Confluence 8 compatible versions of the Scroll Apps mentioned above. We would only recommend updating once Comala Document Management is marked compatible with Confluence 8 and once we have released compatible versions for the integrations apps.