×

You're using an outdated browser

For a better experience, keep your browser up to date. Check here for the latest version.

Manual

What you need to know if you use a snapshot version of one of K15t apps.

Roman Serazhiev

Roman Serazhiev Last update: Jul 11, 2019

Problem

Sometimes you want to participate in beta testing new releases of our products or it is not feasible to wait for the next Atlassian Marketplace release. In such cases, we could offer you to install a snapshot version of the app instead. Snapshot versions are not known to the Atlassian Marketplace and, thus, are handled differently by the Universal Plugin Manager (UPM).

If you install a snapshot version of an app to your Confluence or Jira, you will no longer be notified of updates of that app in the Marketplace. Moreover, you might not be able to install new versions via the Administration > Find new apps.

Environment

  • Any app installed in a snapshot version.
  • Any Server or Data Center deployment for Confluence or Jira

Resolution

Download a released version from the Atlassian Marketplace. To do so, go to the Atlassian Marketplace listing and then go to "Versions". On this page you are able to download a specific released version of an app. Afterwards log in to Confluence or Jira as an administrator and go to Administration > Manage apps.

Uninstall the app using the UPM, also uninstall any bundled plugins that are installed in snapshot versions (see below). Now upload the downloaded artifact of the released version - this will either be a *.jar or *.obr file, depending on the app. After successful installation of the app, you'll be notified of new released versions as usual. 

Additionally, you can also sign in to the Atlassian Marketplace, go to the relevant app's listing and click Watch app. This way you don't miss the release of an app update regardless of what is installed on your Confluence or Jira at the moment. 

Resolution for specific Scroll products

Scroll Versions and Scroll Translations

Uninstall the snapshot versions of Scroll Versions, Scroll Translations, Scroll Platform and Scroll Runtime for Confluence. If any of these are not installed in a snapshot version, you can skip the uninstall for that plugin. Make sure you use the same version for Scroll Versions and Scroll Translations.

Scroll Viewport

Uninstall the snapshot versions of Scroll Viewport and Scroll Runtime for Confluence. If any of these are not installed in a snapshot version, you can skip the uninstall for that plugin.

2x$versions.current.name
We use cookies to create a secure and effective browsing experience for our website visitors and to understand how you use our site (i.e. Google Analytics). For more information: click here.
Ok