Issue type not configured
Symptoms
An issue appears in the troubleshooting section with the category ‘Issue type not configured' and a message containing, e.g. ‘Issue type “Bug” is not configured to accept sync updates.’
Cause
The error occurs in the following scenario:
The advanced setting sync.unsyncedIssueTypes is empty or set to “Any Direction“ or “Configured Direction“
The issue type on the partner side has changed to an issue type that is not included in the sync.
Detailed Example
You are syncing project A and project B with:
Bug ↔︎ Bug
Task ↔︎ Task
You create a Bug PA-1, which creates PB-1
You update PB-1 to issue type “Story“
You update a field, e.g. description, on PA-1
The update is send to PB-1 but can’t be received properly as the issue type Story is not on the incoming side
Resolution
There are two ways to solve this problem:
Switch the issue type back to an issue type that is included in the synchronization
Switch the setting sync.unsyncedIssueTypes in the advanced settings to “All“
After, you can retry the error message.