Worklog User Failure
Symptoms
A worklog on an issue does not get synchronized and appears in the troubleshooting section with the category “User Worklog Failure“ and the message, e.g. “Failed to add worklog: User XX is not an active user or does not have the necessary permissions”
Cause
The user that needs to add the worklog doesn’t exist in the project or doesn’t have the right permissions to add the worklog.
Resolution
To resolve the issue, check if you need to sync the worklogs using the user based mapping? If not, switch to anonymous or enriched.
If you do want to use user based mapping, please check the following if the user that added the worklog exist on both sides.
Exists on both sides: please check if the user has the right permission to add the worklog and after retry the error message
Doesn’t exist on both sides: you can either add the user to the instance, or add a fallback user in the workflow mapping