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Resolve "Failed to acquire lock for" Error

Symptom

The space is locked and the error message "Failed to acquire lock for..." is thrown.

Potential Cause

We lock a space when there is an action from the app that is still in progress, such as publishing a version, deleting versions, or upgrading the app. If Confluence shuts down or crashes during any of these actions, the lock must be manually removed.

Resolution

To resolve this error you need to unlock the space.

Prerequisites

To unlock a space the support resource must be enabled. To enable the support resource follow these steps:

  1. Navigate to Space tools > Scroll Add-ons

  2.  Press the ALT/Option key on your keyboard to make a menu entry for Advanced Scroll Apps Settings appear.

  3. Click on Advanced Scroll Apps Settings

  4. Change the dropdown to Scroll Platform.

  5. Look for "enable.support.resource" in the list of Keys.

  6. Click Edit and set the value as "true."

How to unlock the space

To unlock the space, copy the following command to the browser URL field, replace the values in "< >" and hit enter:

<confluence-url>/rest/scroll-versions/1.0/support/release-publishing-lock/<space_key>

For example: http://mywebsite.com/rest/scroll-versions/1.0/support/release-publishing-lock/PLOCK

To unlock all spaces use this URL instead: <confluence-url>/rest/scroll-versions/latest/support/locks/locked/unlock

If you are publishing to a remote Confluence system and your target space is locked, navigate to the remote Confluence system and send a DELETE request using the following URL: <confluence-url>/rest/scroll-remote-publishing-endpoint/1.0/space/<spaceKey>/publishing-lock

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