Duplicate Scroll Page IDs
This article explains how to find and fix pages that have duplicate Scroll Page IDs.
Symptoms
You ran a health check and saw the following warning:
Following pages have duplicate scrollPageIds….
Possible Causes
Scroll Page IDs are used to link corresponding pages across different versions and translations. This is how the version and language picker knows which page to redirect you to.
Because of this, every page within a single version must have a unique Scroll Page ID. If two pages in the same version share an ID, it can cause problems with operations like saving a version, publishing, or translating.
Duplicate IDs can happen if you, for example, move a page from one version to another.
You can learn more about Scroll Page IDs and Page Groups in our article: Assign Scroll Page IDs and Manage Page Groups
Troubleshoot
To find and fix the duplicate pages, follow these steps:
Run a health check (if you haven't already).
From the Document Manager, click More document actions (•••).
Select Perform health check.
Click Check to run the health check.
If your document contains pages with duplicate Scroll Page IDs, they'll be listed under the warning message “Following pages have duplicate scrollPageIds….”
Inspect the affected pages.
Go back to the Document Manager and click More document actions (•••).
Select Advanced options > Manage page groups.
In one of the columns, click the search bar, the affected pages should appear at the top marked with a warning symbol.
Click on the duplicate entry to view the full Page Group. This will show you the two pages that are causing the conflict.
To resolve the conflict, you have two options, depending on the reason why both pages exist in the version:
Move one of the pages to a different Page Group. To do this, drag the page from the conflicting group to a different group in the other column.
Delete one of the pages that is causing the conflict, depending on your case.